apicloud apicloud

注册
查看: 8297|回复: 122

[公告] AppStore要求必须使用WKWebView说明【5月26日附未更新模块列表】

 

主题:
1077
帖子:
4833
云币:
2147218643

圣诞节捣蛋鬼APICloud大会专属勋章足球狗儿童节快乐

[公告] AppStore要求必须使用WKWebView说明【5月26日附未更新模块列表】

 
8297 122 | 发表于 2020-3-2 13:41:29 |阅读模式 | |
关于App Store要求应用必须使用WKWebView的更新说明


        iOS系统的webView分为UIWebView和WKWebView,目前UIWebView已被标记为废弃API,上传应用到App Store时,可能会收到苹果的提示邮件:

QQ图片20200302133742.png

        目前该邮件只是一个警告提示,依然能够完成应用的上传。根据App Store2019年12月23日的公告,自2020年4月起,App Store将不再接受使用UIWebView的新应用,自2020年12月起将不再接受使用UIWebView的应用的版本更新。参考苹果官方公告https://developer.apple.com/news/?id=12232019b

QQ图片20200302133845.png

        因此,强烈建议开发者尽快将应用切换到WKWebView,关于WKWebView的详细使用可参考https://community.apicloud.com/bbs/thread-151904-1-1.html


        此外,模块Store中,官方和开发者的模块中包含了UIWebView的大部分都已经进行了更新,因此要注意使用模块的最新版本(建议在已添加模块页面勾选上“始终使用模块最新版本”),若是自定义模块使用了UIWebView,则需要自行更新,以免影响应用上传App Store。

在使用WKWebView过程中若遇到问题请及时反馈给技术支持或回复本贴。



以下模块暂时未更新完毕,模块开发者还在努力更新中,请持续关注模块更新状态!

如果您开发的是一个新的应用(第一个iOS版本是4.1日后提交审核的),请不要使用含有UIWebView的模块,以免影响您的审核。对于含有UIWebView还未更新到模块,可以寻找功能相同模块进行替换,或者只使用android版(可在config.xml中配置platform属性值为android)。
无法更新修改WKwebview下架的模块名单:
UIFaceID
baiduLogin
ccVideo
didi
gesturePassword
leCloudLive
leCloudPlay
mobileMove
patternLock
quPai2017
seblePrinter
youZan
youZan2
youkuPlayer
UDYhy
adsDomob
beecloud
bugout
chanceAd
fuQianLa
itppay
itppayPlus
kf5sdk
qiyuSuperSdk
liuLiangQianBao
magicWindow

模块下架:对现有使用这些模块的APP项目不受影响,新创建的APP无法添加使用这些模块。

附截止5月62日10时仍未更新WKwebview模块列表:
facebookAds
jdapp
moxiesdk
snUIWeex
webCapturer
xiaoNeng
yWQModule
adhub
appsee
ipaynow

新手上路

UID:821941

主题:
22
帖子:
101
云币:
124
发表于 2020-3-10 11:04:02 |
想知道为什么配置了WKWebView,发布上app store后还是会收到苹果这样的反馈信息
微信截图_20200310110041.png

主题:
18
帖子:
262
云币:
277
发表于 2020-4-30 23:08:30 |
Web靖龙 发表于 2020-3-10 11:04
想知道为什么配置了WKWebView,发布上app store后还是会收到苹果这样的反馈信息 ...

是的  我也是;配置了还是会收到提示   不知道啥愿意  也没用到未更新成wkwebview的模块

主题:
12
帖子:
79
云币:
87
发表于 2020-3-2 14:04:12 |

回帖奖励 +1

苹果是老大, 上层应用只能跟着跑

主题:
51
帖子:
87
云币:
133
发表于 2020-3-2 14:11:45 |

回帖奖励 +1

请问插件模块,怎么办?

1、官方的插件 什么时候能升级完?   
2、第三方插件,什么时候能完全升级完?
3、会不会有些【官方】、【第三方】插件已经不维护,不更新了呢?

主题:
1077
帖子:
4833
云币:
2147218643

圣诞节捣蛋鬼APICloud大会专属勋章足球狗儿童节快乐

 楼主| 发表于 2020-3-2 14:18:57 |
只爱火星人 发表于 2020-3-2 14:11
请问插件模块,怎么办?

1、官方的插件 什么时候能升级完?   

官方的模块已经更新完毕。
开发者的插件预计3月中旬完成更新,
4月底,可能有一些第三方模块无法更新,我们会保留安卓版本继续上架。

主题:
13
帖子:
64
云币:
197
发表于 2020-3-2 15:04:26 |

回帖奖励 +1

回帖奖励 +1 云币

版主

UID:546828

主题:
34
帖子:
4228
云币:
3015

圣诞节捣蛋鬼APICloud五岁啦

发表于 2020-3-3 10:17:14 |

回帖奖励 +1

回帖奖励 +1 云币

版主

UID:146856

主题:
25
帖子:
2100
云币:
9276

APICloud五岁啦

发表于 2020-3-3 10:40:34 |

回帖奖励 +1

留意一下

驾校小白

UID:835704

主题:
7
帖子:
31
云币:
42
发表于 2020-3-3 10:48:16 |

回帖奖励 +1

虽然看不懂 但是可能用得上

主题:
16
帖子:
6410
云币:
5035
发表于 2020-3-3 14:03:30 |

回帖奖励 +1

金荣鑫 发表于 2020-3-3 10:48
虽然看不懂 但是可能用得上

不是可能是一定。

驾校小白

UID:461463

主题:
4
帖子:
25
云币:
41
发表于 2020-3-4 12:23:41 |

回帖奖励 +1

关注,但是有些模块用最新版本有冲突,去年就碰到一个
您需要登录后才可以回帖 登录 | 立即注册

快速回复 返回顶部 返回列表