apicloud apicloud

注册
楼主: kenny

[APP开发技巧] 【官方】iOS修改Info.plist

 

主题:
24
帖子:
6981
云币:
6505
发表于 2018-5-17 17:51:41 |
飞翔的翔 发表于 2018-5-17 15:40
我配置mipush模块 在info.plist添加ID和Key后没 小米推送注册失败 相同的id和key在Xcode中就可以,这是为什 ...

按照mipush文档,你的Info.plist应该大致这样子,检查下你的配置正确没有,另外注意文件名是Info.plist。

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
    <key>MiSDKAppID</key>
    <string>1000888</string>
    <key>MiSDKAppKey</key>
    <string>500088888888</string>
    <key>MiSDKRun</key>
    <string>Online</string>
</dict>
</plist>

主题:
24
帖子:
141
云币:
207
发表于 2019-5-5 14:53:23 |
技术咨询-Kenny 发表于 2016-5-31 11:00
我私信你了,加我qq说吧,别在这个帖子里盖

版主大大,你好,我也遇到了和这位兄弟一样的问题,请求指点一下。

主题:
24
帖子:
6981
云币:
6505
发表于 2019-5-5 15:31:41 |
zhangcan1168 发表于 2019-5-5 14:53
版主大大,你好,我也遇到了和这位兄弟一样的问题,请求指点一下。

定位权限描述语可以直接在云编译界面添加,不用自己修改Info.plist文件。

主题:
24
帖子:
141
云币:
207
发表于 2019-5-5 15:39:19 |
本帖最后由 zhangcan1168 于 2019-5-5 15:42 编辑
技术咨询-Kenny 发表于 2019-5-5 15:31
定位权限描述语可以直接在云编译界面添加,不用自己修改Info.plist文件。

我确实在云编译界面添加了,但是还是被拒了。  我ios版本用的是api.startLocation()和aMap来实现定位,并且在云编译界面勾选了定位(始终)和定位(使用期间),也填写了描述,第一次上传appStore的时候,审核通过了,但是后来版本迭代(并未修改定位功能,迭代的其他功能),再次上传appStore被拒了,连拒三次,每次都说我的定位描述有问题或者Info.plist中的描述缺失,搞得我现在没有头绪啊。附上被拒邮件,

主题:
24
帖子:
6981
云币:
6505
发表于 2019-5-5 15:51:22 |
zhangcan1168 发表于 2019-5-5 15:39
我确实在云编译界面添加了,但是还是被拒了。  我ios版本用的是api.startLocation()和aMap来实现定位,并 ...

说明是你填写的描述不对,没有说明定位的用途是干嘛的。可以参考下别的应用怎么写的。

主题:
14
帖子:
33
云币:
49
发表于 2019-12-31 19:36:44 |
    <?xml version="1.0" encoding="UTF-8"?>
    <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
    <plist version="1.0">
    <dict>
        <key>LSApplicationQueriesSchemes</key>
        <array>
            <string>weixin</string>
            <string>alipays</string>
            <string>uppaysdk</string>
            <string>uppaywallet</string>
            <string>uppayx1</string>
            <string>uppayx2</string>
            <string>uppayx3</string>
        </array>

    </dict>
    </plist>

按这个配置了Info.plist,然后云编译,提示还是未安装

主题:
24
帖子:
6981
云币:
6505
发表于 2019-12-31 20:01:25 |
中山易达号信息技术 发表于 2019-12-31 19:36
LSApplicationQueriesSchemes
        
            weixin

这个直接在config.xml里面配置即可,避免出错,https://docs.apicloud.com/Dev-Guide/app-config-manual#14-4

主题:
10
帖子:
39
云币:
49
发表于 2020-1-2 10:53:40 |
技术咨询-Kenny 发表于 2019-12-31 20:01
这个直接在config.xml里面配置即可,避免出错,https://docs.apicloud.com/Dev-Guide/app-config-manual# ...

后面配置的5个uppay的在config里面配置不生效,通过云编译测试的。使用自定义模块,微信支付云闪付都返回未安装

主题:
10
帖子:
39
云币:
49
发表于 2020-1-2 10:57:09 |
技术咨询-Kenny 发表于 2019-12-31 20:01
这个直接在config.xml里面配置即可,避免出错,https://docs.apicloud.com/Dev-Guide/app-config-manual# ...

在config里面配置uppay,云编译后提示未安装,调用自定义模块微信支付宝和云闪付都返回未安装

实习司机

UID:793539

主题:
26
帖子:
202
云币:
230
发表于 2020-2-28 14:00:23 |
banner 发表于 2015-11-8 10:57
是我配置的问题,已解决,感谢

请问一下这个配置是怎么配的?
您需要登录后才可以回帖 登录 | 立即注册

快速回复 返回顶部 返回列表